go: bumped minimum required version 1.16

Due to github.com/daixiang0/gci requiring io/fs, the minimum required
Go version for aerc needs to be bumped to 1.16

Signed-off-by: Moritz Poldrack <git@moritz.sh>
Signed-off-by: Robin Jarry <robin@jarry.cc>
main
Moritz Poldrack 4 months ago committed by Robin Jarry
parent 6b1afc3ae3
commit 602a5778e8
  1. 4
      .builds/alpine-edge.yml
  2. 4
      CHANGELOG.md
  3. 4
      README.md
  4. 2
      go.mod

@ -25,8 +25,8 @@ tasks:
cd aerc
go test ./...
- ancient-go-version: |
curl -O https://dl-cdn.alpinelinux.org/alpine/v3.11/community/x86_64/go-1.13.13-r0.apk
sudo apk add ./go-1.13.13-r0.apk
curl -O https://dl-cdn.alpinelinux.org/alpine/v3.14/community/x86_64/go-1.16.15-r0.apk
sudo apk add ./go-1.16.15-r0.apk
cd aerc
make clean
make

@ -29,6 +29,10 @@ The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/).
- Background mail count polling when the default folder is empty on startup.
- Wide character handling in the message list.
### Deprecated
- Support for go < 1.16.
## [0.11.0](https://git.sr.ht/~rjarry/aerc/refs/0.11.0) - 2022-07-11
### Added

@ -64,7 +64,9 @@ And likely other platforms.
Install the dependencies:
- go (>=1.13)
- go (>=1.16) *(Go versions are supported until their end-of-life; support for
older versions may be dropped at any time due to incompatibilities or newer
required language features.)*
- [scdoc](https://git.sr.ht/~sircmpwn/scdoc)
Then compile aerc:

@ -1,6 +1,6 @@
module git.sr.ht/~rjarry/aerc
go 1.13
go 1.16
require (
git.sr.ht/~sircmpwn/getopt v1.0.0

Loading…
Cancel
Save